ACHTUNG. Das ist ein Archiv des alten forum.ruby-portal.de. Die aktuelle Mailingliste gibt es auf lists.ruby-lang.org/pipermail/ruby-de.

NOTICE. This is a ready-only copy of the old forum.ruby-portal.de. You can find the current mailing list at lists.ruby-lang.org/pipermail/ruby-de.

Die Programmiersprache Ruby

Blog|

Forum|

Wiki  


Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]

Ein neues Thema erstellen Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Missing template articles/show
BeitragVerfasst: 17 Sep 2016, 15:33 
Offline
Nuby

Registriert: 11 Aug 2016, 18:34
Beiträge: 3
Hallo

ich versuche gerade mich durch das "Getting Started with Rails" durchzukämpfen.

Soweit so gut!
Allerdings komme ich an einer Fehlermeldung nicht vorbei.

https://blog-kons.c9users.io/articles/9

Ich habe mich eigentlich streng an dieses Totorial gehalten: http://guides.rubyonrails.org/v4.2/getting_started.html

Wieso aber meine "show.htm.erb" aus den views nicht aufgerufen wird kann ich es mir nicht erklären.

Gruß


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Missing template articles/show
BeitragVerfasst: 18 Sep 2016, 10:00 
Offline
Lehrling
Benutzeravatar

Registriert: 28 Feb 2012, 21:58
Beiträge: 86
Wohnort: NRW
Hallo kons und Willkommen bei uns im Forum :)

Es scheint kein schwerer Fehler zu sein aber damit wird dir ein wenig besser helfen können wäre es ganz gut uns mal vielleicht deinen Controller Code zu senden damit wir nachvollziehen können wo der Fehler liegt.

Aber da her auch noch weitere Fragen die vielleicht helfen können:

    1. Sind alle Routing angaben in rake routes richtig ?
    2. Ist das Template im Richtigen Verzeichnis?
    3. Sind im Controller alle Methoden richtig? name == in routes ?

VG Manchotix


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Missing template articles/show
BeitragVerfasst: 18 Sep 2016, 23:14 
Offline
Nuby

Registriert: 11 Aug 2016, 18:34
Beiträge: 3
Hallo und danke für die nette Begrüßung!

Zitat:
Wieso aber meine "show.htm.erb" aus den views nicht aufgerufen wird, kann ich es mir nicht erklären.


Ein "l" vergessen :oops:
"show.html.erb"

Gruß


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Missing template articles/show
BeitragVerfasst: 19 Sep 2016, 07:50 
Offline
Lehrling
Benutzeravatar

Registriert: 28 Feb 2012, 21:58
Beiträge: 86
Wohnort: NRW
Naja, warum das nicht funktioniert wissen wir so auch nicht deswegen wäre es gut wenn du uns den Controller, den Output vom Server oder etwas zeigst damit wir dir auch helfen können ;)


Nach oben
 Profil  
 
 Betreff des Beitrags: Re: Missing template articles/show
BeitragVerfasst: 09 Okt 2016, 12:27 
Offline
Nuby

Registriert: 11 Aug 2016, 18:34
Beiträge: 3
Hi

wie im Post davor erwähnt, hab ich mich einfach verschrieben. Also ein "l" im Dateinamen vergessen.
kons hat geschrieben:
Ein "l" vergessen
"show.html.erb"

Gruß


Sorry, dass ich es zu knapp formuliert habe.


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde [ Sommerzeit ]


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach: